Skip to main content
VulnerabilityPublished

CVE-2026-58205: JeromeDevome GRR · Cross-site Scripting

Affects JeromeDevome GRRSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 4.5.0 soon.

Data as of 27 Oct 2026, 22:57 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade GRR and jeromedevome/GRR to 4.5.0.

Affected software

ProductAffectedFixed in
JeromeDevomeGRRAffected
  • <4.5.0
Fixed in
  • 4.5.0
GitHubjeromedevome/GRRpkg:github/jeromedevome/GRROther threatsAffected
  • <4.5.0
Fixed in
  • 4.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GRR to version 4.5.0 or later, where this vulnerability is fixed. Additionally, ensure that installation files are removed after setup to prevent exposure of the vulnerable parameter. No other mitigation is indicated by the vendor advisory.

Description

JeromeDevome GRR versions prior to 4.5.0 contain a reflected cross-site scripting (XSS) vulnerability in the maj.php script. This occurs when the forcemaj parameter is reflected without proper escaping if installation files remain accessible. An attacker can exploit this by crafting a URL that executes arbitrary JavaScript in a victim's browser, potentially leading to phishing, redirection to malicious sites, cookie theft, and session hijacking due to the authentication cookie not being HttpOnly. The vulnerability is fixed in version 4.5.0.

References

Community reviews

Loading reviews…