CVE-2026-116675: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
Affects tinymceSource GCVE Database
Not known to be exploited · CVSS 8.5 High : upgrade to 8.9.3 soon.
Data as of 27 Oct 2026, 22:12 UTC
- Patch
- Available – fixed in 8.9.3, 7.9.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade tinymce and TinyMCE and tinymce/tinymce to 8.9.3; tinymce and TinyMCE and tinymce/tinymce to 7.9.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmtinymce | Affected
| Fixed in
|
| NuGetTinyMCE | Affected
| Fixed in
|
| Packagisttinymce/tinymce | Affected
| Fixed in
|
| npmtinymce | Affected
| Fixed in
|
| NuGetTinyMCE | Affected
| Fixed in
|
| Packagisttinymce/tinymce | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher. ### Acknowledgements Tiny thanks [Fariskhi Vidyan](https://github.com/farisv) and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
References
- github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-116675 (opens in a new tab)
- github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2 (opens in a new tab)
- github.com/tinymce/tinymce (opens in a new tab)
- github.com/tinymce/tinymce/releases/tag/8.9.3 (opens in a new tab)
- tiny.cloud/docs/tinymce/7/7.9.4-release-notes/ (opens in a new tab)
- tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/ (opens in a new tab)