CVE-2026-47761: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
Affects tinymceSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 7.9.3 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.9.3, 8.5.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade tinymce and TinyMCE and tinymce/tinymce to 7.9.3; tinymce and TinyMCE and tinymce/tinymce to 8.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmtinymce | Affected
| Fixed in– |
| npmtinymce | Affected
| Fixed in
|
| npmtinymce | Affected
| Fixed in
|
| NuGetTinyMCE | Affected
| Fixed in– |
| NuGetTinyMCE | Affected
| Fixed in
|
| NuGetTinyMCE | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade TinyMCE to version 8.5.1 or higher, 7.9.3 or higher, or 5.11.1 LTS or higher. No official workaround is available. Applying the vendor-provided patches is the only recommended remediation.
Description
A stored cross-site scripting (XSS) vulnerability exists in the media plugin of TinyMCE. Attackers can inject malicious scripts via crafted data-mce-* attributes, which execute when the content is rendered. This affects users of TinyMCE with the media plugin enabled. The vulnerability has been patched in TinyMCE versions 8.5.1, 7.9.3, and 5.11.1 LTS.
References
- github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7w (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-47761 (opens in a new tab)
- github.com/tinymce/tinymce (opens in a new tab)
- tiny.cloud/docs/tinymce/7/7.9.3-release-notes/ (opens in a new tab)
- tiny.cloud/docs/tinymce/8/8.5.1-release-notes/ (opens in a new tab)