CVE-2026-47762: TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
Affects tinymceSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 7.9.3 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.9.3, 8.5.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade tinymce and TinyMCE and tinymce/tinymce to 7.9.3; tinymce and TinyMCE and tinymce/tinymce to 8.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmtinymce | Affected
| Fixed in– |
| npmtinymce | Affected
| Fixed in
|
| npmtinymce | Affected
| Fixed in
|
| NuGetTinyMCE | Affected
| Fixed in– |
| NuGetTinyMCE | Affected
| Fixed in
|
| NuGetTinyMCE | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should upgrade to TinyMCE 8.5.1 or later, 7.9.3 or later, or 5.11.1 LTS or later (the latter requires a commercial support contract). There is no official workaround. Applying the official patches is the recommended remediation.
Description
A stored cross-site scripting (XSS) vulnerability exists in TinyMCE through forged mce:protected comments. This flaw allows attackers to bypass sanitization and inject malicious scripts that execute when the protected content is restored. The vulnerability affects users who utilize the protect option in TinyMCE. No official workaround is available. The issue is fixed by validating decoded mce:protected content against configured protect regex rules before restoration. Users should upgrade to TinyMCE 8.5.1 or higher, 7.9.3 or higher, or 5.11.1 LTS or higher (the latter requires a commercial support contract).
References
- github.com/tinymce/tinymce/security/advisories/GHSA-v98h-vmpc-fpqv (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-47762 (opens in a new tab)
- github.com/tinymce/tinymce (opens in a new tab)
- tiny.cloud/docs/tinymce/7/7.9.3-release-notes/ (opens in a new tab)
- tiny.cloud/docs/tinymce/8/8.5.1-release-notes/ (opens in a new tab)