A stored cross-site scripting (XSS) vulnerability exists in TinyMCE through forged mce:protected comments. This flaw allows attackers to bypass sanitization and inject malicious scripts that execute when the protected content is restored. The vulnerability affects users who utilize the protect option in TinyMCE. No official workaround is available. The issue is fixed by validating decoded mce:protected content against configured protect regex rules before restoration. Users should upgrade to TinyMCE 8.5.1 or higher, 7.9.3 or higher, or 5.11.1 LTS or higher (the latter requires a commercial support contract).