Skip to main content
VulnerabilityPublished Updated

CVE-2026-58390: opnsense core · Cross-site Scripting

Affects opnsense coreSource CVE Database V5

0

Not known to be exploited · CVSS 8.0 High : upgrade to 26.1.11 soon.

Data as of 26 Oct 2026, 10:24 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.1.11
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade core and opnsense/core to 26.1.11.

Affected software

ProductAffectedFixed in
opnsensecoreAffected
  • <26.1.11
Fixed in
  • 26.1.11
GitHubopnsense/corepkg:github/opnsense/coreOther threatsAffected
  • <26.1.11
Fixed in
  • 26.1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OPNsense core version 26.1.11. Users should upgrade to version 26.1.11 or later to remediate this vulnerability. No alternative mitigations are indicated in the advisory.

Description

CVE-2026-58390 is a cross-site scripting (XSS) vulnerability in the OPNsense core firewall platform prior to version 26.1.11. It affects the OpenVPN connection-status dashboard widget and view, where a client common_name is inserted into HTML attributes without proper quote-safe encoding. Exploitation requires an OpenVPN server configured with username-as-common-name and RADIUS or LDAP authentication, plus the ability to provision or self-register a username containing a double quote. An authenticated client can inject script that executes in an administrator's session when viewing the dashboard or connection-status page. The vulnerability allows reading config.xml, invoking privileged APIs, resetting the root password, and obtaining root command execution. This issue is fixed in version 26.1.11.

References

Community reviews

Loading reviews…