CVE-2026-58391: opnsense core · Cross-site Scripting
Affects opnsense coreSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 26.1.11 when convenient.
Data as of 26 Oct 2026, 10:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.1.11
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.
What to do
Upgrade core and opnsense/core to 26.1.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| opnsensecore | Affected
| Fixed in
|
GitHubopnsense/corepkg:github/opnsense/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in OPNsense core version 26.1.11. Users should upgrade to version 26.1.11 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A cross-site scripting (XSS) vulnerability exists in OPNsense core prior to version 26.1.11. The issue arises from improper encoding of stored category names and alias descriptions placed into HTML title attributes, allowing injection of script code. An authenticated user with Firewall Categories or Firewall Alias Edit privileges can exploit this by crafting malicious input that executes in the session of an administrator or other user viewing the affected Rules or NAT page. This can lead to unauthorized actions performed with the victim's privileges. The vulnerability is fixed in version 26.1.11.
References
- github.com/opnsense/core/security/advisories/GHSA-2xrm-p255-p43h (opens in a new tab)
- github.com/opnsense/core/commit/5e6313f50546474031805039e209830b63b2b0e4 (opens in a new tab)
- github.com/opnsense/core/commit/fb3b8a07f407ce281b1dde748706acbb0bc514ce (opens in a new tab)
- hackerask.com/posts/opnsense (opens in a new tab)