Skip to main content
VulnerabilityPublished Updated

CVE-2026-5842: decolua 9router · Authorization Bypass

Affects decolua 9routerSource CVE Database V5

0
Compare

Public exploit available · CVSS 6.9 Medium.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
decolua9routerAffected
  • 0.3.0 – 0.3.47
48 affected builds
Fixed in–
GitHubdecolua/9routerpkg:github/decolua/9routerOther threatsAffected
  • <=0.3.47
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the affected decolua 9router component to version 0.3.75, which is confirmed to resolve the authorization bypass vulnerability. Patch status is not explicitly confirmed beyond this upgrade recommendation; verify with the vendor for the latest advisory and patch details.

Description

A security vulnerability has been detected in decolua 9router up to 0.3.47. The impacted element is an unknown function of the file /api of the component Administrative API Endpoint. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 0.3.75 is sufficient to resolve this issue. It is suggested to upgrade the affected component.

References

Community reviews

Loading reviews…