Skip to main content
VulnerabilityPublished

CVE-2026-59157: ncarlier webhookd · Authentication Bypass by Spoofing

Affects ncarlier webhookdSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.22 when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.22, 1.22.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade webhookd to 1.22; ncarlier/webhookd to 1.22.0.

Affected software

ProductAffectedFixed in
ncarlierwebhookdAffected
  • <1.22
Fixed in
  • 1.22
GitHubncarlier/webhookdpkg:github/ncarlier/webhookdOther threatsAffected
  • <1.22.0
Fixed in
  • 1.22.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade webhookd to version 1.22.0 or later, where this vulnerability is fixed. Deployments should also ensure that htpasswd authentication is enabled. Additionally, configure upstream reverse proxies to strip or validate the X-WebAuthn-User header to prevent spoofing. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-59157 is an authentication bypass vulnerability in webhookd versions prior to 1.22.0. The issue arises when deployments without htpasswd authentication forward all incoming HTTP headers into hook script environments without an allowlist. Specifically, if an upstream reverse proxy does not strip the client-supplied X-WebAuthn-User header, a remote unauthenticated attacker can spoof this header to impersonate another user. This allows bypassing script security controls and accessing or modifying resources with the impersonated identity's privileges. The vulnerability is fixed in webhookd version 1.22.0.

References

Community reviews

Loading reviews…