CVE-2026-59158: thoda-dev nuxt-ollama · Insufficiently Protected Credentials
Affects thoda-dev nuxt-ollamaSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.3.1 soon.
Data as of 27 Oct 2026, 22:57 UTC
- Patch
- Available – fixed in 1.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nuxt-ollama and thoda-dev/nuxt-ollama to 1.3.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| thoda-devnuxt-ollama | Affected
| Fixed in
|
GitHubthoda-dev/nuxt-ollamapkg:github/thoda-dev/nuxt-ollamaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade nuxt-ollama to version 1.3.1 or later, where the issue is fixed by not exposing the cloud api_key in the public runtime configuration.
Description
CVE-2026-59158 is a vulnerability in nuxt-ollama versions prior to 1.3.1 where an API key configured for cloud access is exposed in the client-side HTML payload. This exposure occurs because the module options, including the cloud api_key, are merged into a public runtime configuration that Nuxt serializes into the server-rendered HTML. As a result, unauthenticated clients can retrieve the API key in plaintext, enabling unauthorized use of the cloud API. The issue is fixed in version 1.3.1.