CVE-2026-32633: Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist`
Affects GlancesSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.5.2 as a priority.
Data as of 27 Oct 2026, 17:29 UTC
- Patch
- Available – fixed in 4.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Glances to 4.5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIGlances | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Glances version 4.5.2 that addresses this vulnerability. Users should upgrade to version 4.5.2 or later. Until patched, it is recommended to always start the Glances Browser/API instance with the `--password` option to enforce authentication on the API endpoints, preventing unauthenticated access to the `/api/4/serverslist` endpoint. Additionally, restricting network access to the Glances Browser API to trusted users only can reduce exposure.
Description
Glances versions prior to 4.5.2 have a critical vulnerability in the Central Browser mode where the `/api/4/serverslist` endpoint exposes reusable downstream credentials via the `uri` field. When the front Glances Browser/API instance is started without a password, this endpoint is unauthenticated and returns server objects containing HTTP Basic authentication credentials derived from a pbkdf2 hash. These credentials can be accessed by any network user able to reach the API, potentially allowing unauthorized access to protected downstream Glances servers. The vulnerability is fixed in version 4.5.2.
References
- github.com/nicolargo/glances/security/advisories/GHSA-r297-p3v4-wp8m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-32633 (opens in a new tab)
- github.com/nicolargo/glances/commit/879ef8688ffa1630839549751d3c7ef9961d361e (opens in a new tab)
- github.com/nicolargo/glances (opens in a new tab)
- github.com/nicolargo/glances/releases/tag/v4.5.2 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/glances/PYSEC-2026-343.yaml (opens in a new tab)
- pypi.org/project/glances (opens in a new tab)