Skip to main content
CVE-2026-34839VulnerabilityPublished Updated

Glances: Cross-Origin Information Disclosure via Unauthenticated REST API (/api/4) due to Permissive CORS

Affects GlancesSource GCVE Database

0
Authoritative record:CVE-2026-34839· High 7.7

Public exploit available · CVSS 7.7 High : upgrade to 4.5.4 as a priority.

Data as of 27 Oct 2026, 01:25 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Glances to 4.5.4.

Affected software

ProductAffectedFixed in
PyPIGlancesAffected
  • <4.5.4
Fixed in
  • 4.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Glances version 4.5.4 that fixes this vulnerability. Users should upgrade to version 4.5.4 or later. Until patched, avoid running Glances in web mode exposed to untrusted networks or restrict access to trusted origins. Consider configuring CORS policies to limit allowed origins.

Description

Glances versions prior to 4.5.4 expose a REST API endpoint (/api/4/all) without authentication and with a permissive CORS policy allowing any origin. This enables malicious websites to read sensitive system information from a victim's browser, including process lists, system details, memory, disk usage, and network configuration. The vulnerability requires only that the victim visits a malicious web page while running Glances in web mode. A fix is available in version 4.5.4.

References

Community reviews

Loading reviews…