OpenPanel before 3.0.0 contains an information disclosure vulnerability that allows read-level project members to
Affects openpanelSource GCVE Database
Not known to be exploited · CVSS 8.4 High : upgrade to 3.0.0 soon.
Data as of 27 Oct 2026, 01:58 UTC
- Patch
- Available – fixed in 3.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade openpanel-dev/openpanel to 3.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubopenpanel-dev/openpanelpkg:github/openpanel-dev/openpanelOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Since the vulnerability affects OpenPanel versions before 3.0.0, upgrading to version 3.0.0 or later is implied to remediate the issue. Until an official fix is confirmed, restrict read-level access to trusted users only and monitor for any suspicious activity involving integration credentials.
Description
OpenPanel versions before 3.0.0 have an information disclosure vulnerability that allows users with read-level project access to retrieve sensitive integration secrets. This occurs because the notification.rules query does not properly redact integration credentials. Exploiting this flaw, attackers can obtain Slack bot tokens, webhook URLs, and authorization headers, potentially enabling unauthorized actions against external systems.
References
- github.com/Openpanel-dev/openpanel/security/advisories/GHSA-wfrw-rm3f-52x8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-116819 (opens in a new tab)
- github.com/Openpanel-dev/openpanel/commit/071c736c4539c005ac32647f2cfc6dec89cfb596 (opens in a new tab)
- vulncheck.com/advisories/openpanel-before-3.0.0-credential-disclosure-via-notification-rules-query (opens in a new tab)