Org.apache.wicket:wicket parent: Apache Wicket has an Exposure of Sensitive Information to an Unauthorized Actor
Affects org.apache.wicket:wicket-parentSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 10.9.0 soon.
Data as of 27 Oct 2026, 00:58 UTC
- Patch
- Available – fixed in 10.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.wicket:wicket-parent to 10.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.wicket:wicket-parent | Affected
| Fixed in– |
| Mavenorg.apache.wicket:wicket-parent | Affected
| Fixed in– |
| Mavenorg.apache.wicket:wicket-parent | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to version 10.9.0 or later, where this vulnerability is fixed. Since a patch is available and the issue is resolved in the fixed version, applying this update is the recommended remediation.
Description
Apache Wicket versions from 8.0.0 through 8.17.0, 9.0.0 through 9.22.0, and 10.0.0 through 10.8.0 contain a vulnerability that exposes sensitive information to unauthorized actors. This issue is resolved in version 10.9.0. The vulnerability has a high severity with a CVSS score of 7.5, indicating network exploitable exposure with no privileges or user interaction required.