CVE-2026-42509: Org.apache.wicket:wicket parent: Apache Wicket has a Cross-site Scripting issue
Affects org.apache.wicket:wicket-parentSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 10.9.0 when convenient.
Data as of 27 Oct 2026, 00:07 UTC
- Patch
- Available – fixed in 10.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.wicket:wicket-parent to 10.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.wicket:wicket-parent | Affected
| Fixed in– |
| Mavenorg.apache.wicket:wicket-parent | Affected
| Fixed in– |
| Mavenorg.apache.wicket:wicket-parent | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.