Skip to main content
VulnerabilityPublished

CVE-2026-59176: jordanburke functype · Untrusted Functionality Inclusion

Affects jordanburke functypeSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 1.4.4 soon.

Data as of 28 Oct 2026, 14:00 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.4.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jordanburke functype to 1.4.4.

Affected software

ProductAffectedFixed in
jordanburkefunctypeAffected
  • <1.4.4
Fixed in
  • 1.4.4

AI-suggested

Upgrade functype to version 1.4.4 or later, where the vulnerability is fixed. The vendor advisory confirms the fix in version 1.4.4. Until upgraded, restrict access to the MCP tool invocation interface, especially in stdio mode where it is enabled by default without authentication. For deployments using `TRANSPORT_TYPE=httpStream`, ensure network access controls prevent unauthorized invocation. No other mitigations are specified by the vendor.

Description

CVE-2026-59176 affects the functype TypeScript functional programming libraries prior to version 1.4.4. The vulnerability arises from the MCP tool `set_functype_version` accepting an unconstrained version string that can include package-alias syntaxes, allowing arbitrary local or remote packages to be installed and executed with MCP server privileges. This can lead to execution of attacker-controlled JavaScript code. The flaw is exploitable by any MCP client invoking the tool, which is enabled by default without authentication in stdio mode, and potentially by a connected AI assistant vulnerable to indirect prompt injection. The issue is fixed in version 1.4.4.

References

Community reviews

Loading reviews…