CVE-2026-114053: vLLM · Request-controlled mm_processor_kwargs.code_revision allows remote code execution
Affects vllmSource GCVE Database
Not known to be exploited · CVSS 9.2 Critical : upgrade to 0.31.0 as a priority.
Data as of 27 Oct 2026, 16:29 UTC
- Patch
- Available – fixed in 0.31.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm to 0.31.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIvllm | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of vLLM is available starting at 0.31.0; operators should upgrade to this version or later. If upgrading is not immediately possible, operators should disable the trust_remote_code option to prevent dynamic code execution from untrusted revisions. Additionally, protect the /tokenize endpoint with authentication or an external proxy to prevent unauthenticated access. The default configuration with trust_remote_code disabled is not vulnerable.
Description
vLLM versions from 0.7.3 up to but not including 0.31.0 have a vulnerability where an attacker can control the mm_processor_kwargs.code_revision parameter in multimodal requests. When the operator enables trust_remote_code and serves a model whose Hugging Face processor uses dynamic auto_map code, this allows the attacker to execute arbitrary Python code by importing a malicious processor module revision. The vulnerability is exploitable via unauthenticated /tokenize endpoints unless protected externally. A fix is available in vLLM version 0.31.0.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-6mm3-gc2m (opens in a new tab)
- github.com/vllm-project/vllm/pull/58830 (opens in a new tab)
- github.com/vllm-project/vllm/commit/31f2e70cd3e403aaa471fb7fe3d33a7207aaf3cc (opens in a new tab)
- github.com/vllm-project/vllm (opens in a new tab)
- github.com/vllm-project/vllm/releases/tag/v0.31.0 (opens in a new tab)
- nvd.nist.gov/vuln/detail/cve-2026-114053 (opens in a new tab)
- vulncheck.com/advisories/vllm-0.7.3-before-0.31.0-rce-via-mm-processor-kwargs-code-revision (opens in a new tab)