CVE-2025-66448: vllm · Code Injection
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 0.11.1 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.11.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm to 0.11.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all vllm deployments to version 0.11.1 or later to eliminate this vulnerability. Until upgrades are completed, organizations must implement strict validation and whitelisting of model configurations and repositories before loading them into vllm, ensuring only trusted sources are used. Network controls should be enforced to restrict vllm’s ability to fetch code from untrusted external repositories, including firewall rules and proxy filtering. Monitoring and alerting for unusual outbound connections from vllm hosts can help detect exploitation attempts. Additionally, organizations should adopt supply chain security best practices, such as verifying the provenance and integrity of AI model repositories and using cryptographic signatures where possible. Educating developers and data scientists about the risks of loading untrusted model configurations is critical. Finally, consider isolating vllm inference environments using containerization or sandboxing to limit the impact of potential code execution.
Description
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.11.1, vllm has a critical remote code execution vector in a config class named Nemotron_Nano_VL_Config. When vllm loads a model config that contains an auto_map entry, the config class resolves that mapping with get_class_from_dynamic_module(...) and immediately instantiates the returned class. This fetches and executes Python from the remote repository referenced in the auto_map string. Crucially, this happens even when the caller explicitly sets trust_remote_code=False in vllm.transformers_utils.config.get_config. In practice, an attacker can publish a benign-looking frontend repo whose config.json points via auto_map to a separate malicious backend repo; loading the frontend will silently run the backend’s code on the victim host. This vulnerability is fixed in 0.11.1.