Skip to main content
VulnerabilityPublished

CVE-2026-44336: PraisonAI MCP `tools/call` path-traversal => RCE via Python `.pth` injection

Affects PraisonAISource GCVE Database

0
Authoritative record:CVE-2026-44336· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical : upgrade to 4.6.34 as a priority.

Data as of 27 Oct 2026, 00:58 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.34
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PraisonAI to 4.6.34.

Affected software

ProductAffectedFixed in
PyPIPraisonAIAffected
  • <4.6.34
Fixed in
  • 4.6.34

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to PraisonAI MCP version 4.6.34 or later, where this vulnerability is fixed. No other configuration changes or mitigations are indicated by the vendor advisory. Users should ensure they are not running vulnerable versions and avoid exposing the MCP server without authentication.

Description

PraisonAI MCP server has a critical path traversal vulnerability in its file-handling tools that allows an attacker to write arbitrary files outside the intended directory. This can be exploited to drop malicious Python .pth files into the user's site-packages directory, leading to arbitrary code execution in any subsequent Python process run by the user. The vulnerability arises from lack of input validation and containment checks in four default tools that accept file paths. Exploitation can occur without operator misconfiguration and can be triggered via MCP-connected LLMs or local processes. A fix is available in version 4.6.34.

References

Community reviews

Loading reviews…