Skip to main content
VulnerabilityPublished

CVE-2026-59675: SUSE Rancher · Uncontrolled Resource Consumption / Input Handling

Affects SUSE RancherSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 2.14.4 : patch SUSE Rancher soon.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.4, 2.13.8, 2.12.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade SUSE Rancher to 2.14.4, 2.13.8 or 2.12.12.

Affected software

ProductAffectedFixed in
SUSERancherAffected
  • >=2.14.0 <2.14.4
Fixed in
  • 2.14.4
SUSERancherAffected
  • >=2.13.0 <2.13.8
Fixed in
  • 2.13.8
SUSERancherAffected
  • >=2.12.0 <2.12.12
Fixed in
  • 2.12.12
GitHubrancher/rancherpkg:github/rancher/rancherOther threatsAffected
  • =2.12.0
  • =2.13.0
  • =2.14.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider disabling API audit logging if feasible or implementing external protections such as rate limiting or network-level controls to restrict large request bodies to the login endpoints.

Description

CVE-2026-59675 is a high-severity vulnerability in SUSE Rancher versions 2.12.0, 2.13.0, and 2.14.0. When API audit logging is enabled, the middleware reads the entire HTTP request body into memory without size limits on login endpoints, bypassing the intended 1 MiB cap. This allows an unauthenticated attacker to send very large request bodies, causing excessive memory consumption and potential denial of service by crashing the Rancher Manager process, which disrupts API and UI availability and management of downstream clusters.

References

Community reviews

Loading reviews…