Skip to main content
VulnerabilityPublished

CVE-2026-59878: Apache ActiveMQ AMQP · Improper Input Validation

Affects Apache ActiveMQ AMQPSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 6.2.8 or 5.19.9 soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.8, 5.19.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 6.2.8 or 5.19.9.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ AMQPAffected
  • >=6.0.0 <6.2.8
Fixed in
  • 6.2.8
Apache Software FoundationApache ActiveMQ AMQPAffected
  • <5.19.9
Fixed in
  • 5.19.9
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.8
Fixed in
  • 6.2.8
Apache Software FoundationApache ActiveMQAffected
  • <5.19.9
Fixed in
  • 5.19.9
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.8
Fixed in
  • 6.2.8
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.9
Fixed in
  • 5.19.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ AMQP and Apache ActiveMQ to versions 5.19.9, 6.2.8, or later (e.g., 6.3.0) where this vulnerability is fixed. Patch status is confirmed by the vendor advisory recommending these versions. No other mitigations or temporary fixes are indicated.

Description

Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.

References

Community reviews

Loading reviews…