Skip to main content
VulnerabilityPublished Updated

CVE-2026-74761: Apache ActiveMQ Broker · Improper Input Validation

Affects Apache ActiveMQ BrokerSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 6.3.2 or 5.19.11 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-10.

Patch
Available – fixed in 6.3.2, 5.19.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 6.3.2 or 5.19.11.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.3.2
Fixed in
  • 6.3.2
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.11
Fixed in
  • 5.19.11
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.3.2
Fixed in
  • 6.3.2
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.11
Fixed in
  • 5.19.11
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.3.2
Fixed in
  • 6.3.2
Apache Software FoundationApache ActiveMQAffected
  • <5.19.11
Fixed in
  • 5.19.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ Broker to version 5.19.11 or 6.3.2 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

CVE-2026-74761 is an improper input validation vulnerability in the TopicRegion component of Apache ActiveMQ Broker. An authenticated client can spoof the clientId when removing a durable topic subscription, potentially impacting the integrity of subscription management. This affects Apache ActiveMQ Broker versions before 5.19.11 and versions from 6.0.0 before 6.3.2. Upgrading to versions 5.19.11 or 6.3.2 resolves the issue.

References

Community reviews

Loading reviews…