Skip to main content
VulnerabilityPublished Updated

CVE-2026-34197: Apache ActiveMQ Broker · Improper Input Validation

Affects Apache ActiveMQ BrokerSource CVE Database V5

0
Compare

Exploited in the wild · KEV due 30 Apr 2026 · public exploit available (Metasploit) · 98% EPSS : upgrade to 6.2.3 or 5.19.4 now.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
98.2% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.3, 5.19.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Weaponized: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 9 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Apache Software Foundation

    , 12 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 26 minutes after disclosure

  4. , 9 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 23 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ActiveMQ Broker and Apache ActiveMQ All and Apache ActiveMQ and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:apache-activemq and org.apache.activemq/activemq-broker to 6.2.3 or 5.19.4.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.3
Fixed in
  • 6.2.3
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.4
Fixed in
  • 5.19.4
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.3
Fixed in
  • 6.2.3
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.4
Fixed in
  • 5.19.4
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.3
Fixed in
  • 6.2.3
Apache Software FoundationApache ActiveMQAffected
  • <5.19.4
Fixed in
  • 5.19.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

References

Community reviews

Loading reviews…