Skip to main content
VulnerabilityPublished Updated

CVE-2026-40466: Apache ActiveMQ Broker · Improper Input Validation

Affects Apache ActiveMQ BrokerSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · public detection template (Nuclei) · CVSS 8.8 High : upgrade to 6.2.5 or 5.19.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.7% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.5, 5.19.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ActiveMQ Broker and Apache ActiveMQ All and Apache ActiveMQ and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:apache-activemq and org.apache.activemq/activemq-broker to 6.2.5 or 5.19.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.6
Fixed in
  • 5.19.6
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.6
Fixed in
  • 5.19.6
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Apache Software FoundationApache ActiveMQAffected
  • <5.19.6
Fixed in
  • 5.19.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Apache ActiveMQ Broker to version 5.19.6 or 6.2.5 or later, which address this vulnerability. There is no indication from the vendor advisory that alternative mitigations or temporary fixes are available or recommended. Patch status is confirmed by the vendor advisory.

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath. A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.

References

Community reviews

Loading reviews…