Skip to main content
VulnerabilityPublished Updated

CVE-2026-41044: Apache ActiveMQ · Improper Input Validation

Affects Apache ActiveMQSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 6.2.5 or 5.19.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.5, 5.19.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache ActiveMQ and Apache ActiveMQ Broker and Apache ActiveMQ All and Apache Software Foundation/org.apache.activemq:apache-activemq and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and org.apache.activemq/activemq-broker to 6.2.5 or 5.19.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Apache Software FoundationApache ActiveMQAffected
  • <5.19.6
Fixed in
  • 5.19.6
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.6
Fixed in
  • 5.19.6
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.6
Fixed in
  • 5.19.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users are strongly advised to upgrade Apache ActiveMQ to version 5.19.6 or 6.2.5, which address this vulnerability. Patch status is confirmed by the vendor advisory. No alternative mitigations are indicated in the advisory.

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All. An authenticated attacker can use the admin web console page to construct a malicious broker name that bypasses name validation to include an xbean binding that can be later used by a VM transport to load a remote Spring XML application. The attacker can then use the DestinationView mbean to send a message to trigger a VM transport creation that will reference this malicious broker name which can lead to loading the malicious Spring XML context file. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

References

Community reviews

Loading reviews…