Skip to main content
VulnerabilityPublished Updated

CVE-2026-6104: PHP · Out-of-bounds Read

Affects PHPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 8.5.6 or 8.4.21 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.6, 8.4.21, 8.6.0 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:L/SI:N/SA:L/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PHP to 8.5.6 or 8.4.21; php/php-src to 8.6.0, 8.5.6, 8.5.0 or 8.4.21.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.5.*, < 8.5.6
Fixed in
  • 8.5.6
PHP GroupPHPAffected
  • ≥ 8.4.*, < 8.4.21
Fixed in
  • 8.4.21
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • <8.4.21
  • >=8.4.0 <8.5.0
  • <8.5.6
  • >=8.5.0 <8.6.0
Fixed in
  • 8.4.21
  • 8.5.0
  • 8.5.6
  • 8.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in PHP versions 8.4.21 and 8.5.6. Users should upgrade affected PHP installations to these or later versions to remediate the issue. Red Hat has released updated PHP 8.4 packages addressing this vulnerability for Red Hat Enterprise Linux 10. No alternative mitigations are indicated in the vendor advisory.

Description

In PHP versions 8.4.* before 8.4.21 and 8.5.* before 8.5.6, when an encoding name containing an embedded NUL byte is passed to mb_convert_encoding() or related mbstring functions, the code incorrectly assumes that when strncasecmp() returns 0 it means the strings have the same length. This can lead to out-of-bounds read of global memory, potentially causing a crash or information disclosure or crash. Affected functions include mb_convert_encoding(), mb_detect_encoding(), mb_convert_variables(), and mb_detect_order(), as well as the mbstring.detect_order and mbstring.http_output INI settings.

References

Community reviews

Loading reviews…