Skip to main content
VulnerabilityPublished

CVE-2026-61487: Apache ActiveMQ Broker · Improper Authorization

Affects Apache ActiveMQ BrokerSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.2.8 or 5.19.9 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.8, 5.19.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 6.2.8 or 5.19.9.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.8
Fixed in
  • 6.2.8
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.9
Fixed in
  • 5.19.9
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.8
Fixed in
  • 6.2.8
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.9
Fixed in
  • 5.19.9
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.8
Fixed in
  • 6.2.8
Apache Software FoundationApache ActiveMQAffected
  • <5.19.9
Fixed in
  • 5.19.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ Broker to version 5.19.9, 6.2.8, or 6.3.0 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor advisory recommending these fixed versions.

Description

Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.

References

Community reviews

Loading reviews…