CVE-2026-61618: axiom-crypto snark-verifier · Improper Input Validation
Affects axiom-crypto snark-verifierSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.2.5 when convenient.
Data as of 30 Oct 2026, 20:18 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 0.2.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade snark-verifier and axiom-crypto/snark-verifier to 0.2.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| axiom-cryptosnark-verifier | Affected
| Fixed in
|
GitHubaxiom-crypto/snark-verifierpkg:github/axiom-crypto/snark-verifierOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to axiom-crypto snark-verifier version 0.2.5 or later, where the issue is fixed by enforcing canonical limb bounds before elliptic-curve coordinate reconstruction. No other mitigation is required as the fix is available.
Description
CVE-2026-61618 is an improper input validation vulnerability in axiom-crypto's snark-verifier prior to version 0.2.5. The issue arises because KZG accumulator public-instance limbs are decoded without enforcing canonical limb bounds before elliptic-curve coordinate reconstruction. This can lead to noncanonical encodings reaching the verifier boundary and potentially causing a crash in the native verifier. The vulnerability is fixed in version 0.2.5.