Skip to main content
VulnerabilityPublished

CVE-2026-62335: openvm · Improper Input Validation

Affects openvmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium · fixed in 2.1.0-preview : update openvm when convenient.

Data as of 30 Oct 2026, 20:19 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.06.9
Patch
Available – fixed in 2.1.0-preview, 2.0.0-rc.3, 1.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade openvm to 2.1.0-preview, 2.0.0-rc.3 or 1.7.0.

Affected software

ProductAffectedFixed in
openvm-orgopenvmAffected
  • >=2.1.0-dev.0 <2.1.0-preview
Fixed in
  • 2.1.0-preview
openvm-orgopenvmAffected
  • >=2.0.0-alpha <2.0.0-rc.3
Fixed in
  • 2.0.0-rc.3
openvm-orgopenvmAffected
  • <1.7.0
Fixed in
  • 1.7.0

AI-suggested

A patch is available and should be applied by upgrading to OpenVM versions 1.7.0, 2.0.0-rc.3, or 2.1.0-preview or later. Since this is a cloud service, the vendor manages remediation for the cloud-hosted service; users should verify with the vendor that their environment is updated accordingly.

Description

CVE-2026-62335 is an improper input validation vulnerability in openvm-org's OpenVM zkVM framework. Versions before 1.7.0 in the 1.x line, and certain prereleases of 2.0 and 2.1, allow the verify function to accept non-canonical 256-bit values for app executable and VM commitments without verifying they are less than the BN254 scalar field modulus. This can cause ambiguity between the byte-level inputs and the field elements used by the verifier. The issue is fixed in versions 1.7.0, 2.0.0-rc.3, and 2.1.0-preview.

References

Community reviews

Loading reviews…