Skip to main content
VulnerabilityPublished Updated

CVE-2026-61700: mariadb-connector-j · Improper Access Control

Affects mariadb-connector-jSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.7 Low · fixed in 3.5.9 : update mariadb-connector-j when convenient.

Data as of 1 Nov 2026, 11:03 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.9, 3.4.3, 3.3.5 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade mariadb-connector-j and org.mariadb.jdbc/mariadb-connector-j to 3.5.9, 3.4.3, 3.3.5 or 2.7.14.

Affected software

ProductAffectedFixed in
mariadb-corporationmariadb-connector-jAffected
  • >=3.5.0 <3.5.9
Fixed in
  • 3.5.9
mariadb-corporationmariadb-connector-jAffected
  • >=3.4.0 <3.4.3
Fixed in
  • 3.4.3
mariadb-corporationmariadb-connector-jAffected
  • >=3.0.0 <3.3.5
Fixed in
  • 3.3.5
mariadb-corporationmariadb-connector-jAffected
  • <2.7.14
Fixed in
  • 2.7.14
Mavenorg.mariadb.jdbc/mariadb-connector-jpkg:maven/org.mariadb.jdbc/mariadb-connector-jOther threatsAffected
  • <2.7.14
  • >=3.0.0 <3.3.5
  • >=3.4.0 <3.4.3
  • >=3.5.0 <3.5.9
Fixed in
  • 2.7.14
  • 3.3.5
  • 3.4.3
  • 3.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade MariaDB Connector/J to version 2.7.14, 3.3.5, 3.4.3, or 3.5.9 or later where this issue is fixed. No other mitigations are indicated by the vendor advisory. Patch status is confirmed fixed in these versions.

Description

CVE-2026-61700 is an improper access control vulnerability in MariaDB Connector/J affecting versions prior to 2.7.14, 3.3.5, 3.4.3, and 3.5.9. The flaw allows a rogue or man-in-the-middle server to cause the connector to transmit a local file despite the allowLocalInfile option being disabled, but only the exact file requested by the application can be sent. Exploitation requires an application that loads sensitive data over an untrusted connection. This issue has a CVSS score of 3.7 (medium severity) and is fixed in the specified versions.

References

Community reviews

Loading reviews…