CVE-2026-61814: typelevel jawn · Uncontrolled Resource Consumption
Affects typelevel jawnSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.7.0 soon.
Data as of 7 Nov 2026, 23:24 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade jawn and jawn-parser_2.12 and jawn-parser_2.13 and jawn-parser_3 and typelevel/jawn to 1.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| typeleveljawn | Affected
| Fixed in
|
| org.typeleveljawn-parser_2.12 | Affected
| Fixed in
|
| org.typeleveljawn-parser_2.13 | Affected
| Fixed in
|
| org.typeleveljawn-parser_3 | Affected
| Fixed in
|
GitHubtypelevel/jawnpkg:github/typelevel/jawnOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to jawn version 1.7.0 or later, where this issue is fixed. No other mitigation is indicated.
Description
Jawn is an open source JSON parser with a vulnerability in its AsyncParser component prior to version 1.7.0. The AsyncParser can perform quadratic work when processing a single JSON token delivered in many small chunks, leading to excessive CPU consumption. This can be exploited by a remote attacker controlling untrusted JSON input and chunk sizes to cause a denial of service. The issue is fixed in version 1.7.0.