Skip to main content
VulnerabilityPublished

CVE-2026-61817: pgpartman pg_partman · SQL Injection

Affects pgpartman pg_partmanSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 5.5.0 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade pg_partman and pgpartman/pg_partman to 5.5.0.

Affected software

ProductAffectedFixed in
pgpartmanpg_partmanAffected
  • <5.5.0
Fixed in
  • 5.5.0
GitHubpgpartman/pg_partmanpkg:github/pgpartman/pg_partmanOther threatsAffected
  • <5.5.0
Fixed in
  • 5.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pg_partman to version 5.5.0 or later, where this SQL injection vulnerability is fixed. No other mitigation or temporary workaround is indicated. Users should apply the official fix to prevent exploitation.

Description

CVE-2026-61817 is a high-severity SQL injection vulnerability in the pg_partman PostgreSQL extension prior to version 5.5.0. It arises from improper neutralization of special elements in dynamic SQL commands related to the part_config.time_dncoder value. A user with partman_user privileges can inject arbitrary SQL that executes with elevated privileges, potentially leading to full database compromise and operating system command execution. The issue is fixed in pg_partman version 5.5.0.

References

Community reviews

Loading reviews…