Skip to main content
VulnerabilityPublished

CVE-2026-61821: pgpartman pg_partman · Missing Authorization

Affects pgpartman pg_partmanSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 5.5.0 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade pg_partman and pgpartman/pg_partman to 5.5.0.

Affected software

ProductAffectedFixed in
pgpartmanpg_partmanAffected
  • <5.5.0
Fixed in
  • 5.5.0
GitHubpgpartman/pg_partmanpkg:github/pgpartman/pg_partmanOther threatsAffected
  • <5.5.0
Fixed in
  • 5.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pg_partman to version 5.5.0 or later, where this authorization bypass vulnerability is fixed. No other mitigations are specified or required once the patch is applied.

Description

CVE-2026-61821 is a high-severity authorization bypass vulnerability in the pg_partman PostgreSQL extension prior to version 5.5.0. It allows a role with partman_user access to relocate retained child tables between schemas without proper CREATE privileges, exploiting the background worker's superuser-level privileges. This bypasses normal ALTER TABLE SET SCHEMA authorization checks. The issue is fixed in pg_partman version 5.5.0.

References

Community reviews

Loading reviews…