CVE-2026-61846: rgrove crass · Uncontrolled Recursion
Affects rgrove crassSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.0.7 when convenient.
Data as of 30 Oct 2026, 20:38 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 6.3 |
|---|
- Patch
- Available – fixed in 1.0.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade rgrove crass to 1.0.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rgrovecrass | Affected
| Fixed in
|
RubyGemscrasspkg:gem/crassOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Crass version 1.0.7 or later, which includes a configurable recursion depth limit to prevent uncontrolled recursion. No other mitigation is required as the issue is fixed in this version.
Description
Crass, a Ruby CSS parser, had an uncontrolled recursion vulnerability in versions prior to 1.0.7. The parser recursively processed CSS simple blocks and functions without limiting recursion depth, allowing an attacker to craft deeply nested CSS values that cause a stack overflow or excessive memory use. This issue is fixed in version 1.0.7 by adding a configurable recursion depth limit with a conservative default.