CVE-2026-61850: akuity kargo · Improper Privilege Management
Affects akuity kargoSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical · fixed in 1.10.8 : patch akuity kargo as a priority.
Data as of 30 Oct 2026, 20:43 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 9.3 |
|---|
- Patch
- Available – fixed in 1.10.8, 1.9.9, 1.8.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade akuity kargo to 1.10.8, 1.9.9 or 1.8.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| akuitykargo | Affected
| Fixed in
|
| akuitykargo | Affected
| Fixed in
|
| akuitykargo | Affected
| Fixed in
|
AI-suggested
A fix is available and included in akuity kargo versions 1.8.14, 1.9.9, and 1.10.8. Users should upgrade to these versions or later to remediate this vulnerability. Since this is a cloud service, the vendor manages remediation for the cloud-hosted service; verify with the vendor advisory that the service is patched accordingly. No additional mitigation steps are indicated beyond applying the official fix.
Description
A critical improper privilege management vulnerability (CWE-269) exists in akuity kargo versions from 0.6.0 up to but not including 1.8.14, 1.9.9, and 1.10.8. Authenticated users with delegated permission to manage a Project's Roles or ServiceAccounts can escalate their privileges beyond their own permissions. This allows escalation to Project-administrator access, disclosure of Project secrets and credentials, and modification or deletion of Project resources. Exploitation requires an administrator-created custom role granting relevant permissions and control of an account assigned that role. The issue is fixed in versions 1.8.14, 1.9.9, and 1.10.8.
References
- github.com/akuity/kargo/security/advisories/GHSA-wp4p-hr79-q4g8 (opens in a new tab)
- github.com/akuity/kargo/commit/19639678811b486bddb014dabb25397771f3941e (opens in a new tab)
- github.com/akuity/kargo/commit/50d29c10153965114f903645c83eadbe7bf58d3f (opens in a new tab)
- github.com/akuity/kargo/commit/5ab7c4216a4151f55ea8ef9ff3b9f884dd322578 (opens in a new tab)
- github.com/akuity/kargo/commit/72fadd3600b35e6dce67042eb686720a48b45fa3 (opens in a new tab)
- github.com/akuity/kargo/releases/tag/v1.10.8 (opens in a new tab)
- github.com/akuity/kargo/releases/tag/v1.11.0-rc.1 (opens in a new tab)
- github.com/akuity/kargo/releases/tag/v1.8.14 (opens in a new tab)
- github.com/akuity/kargo/releases/tag/v1.9.9 (opens in a new tab)