CVE-2026-24748: akuity kargo · Incorrect Authorization
Affects akuity kargoSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium · fixed in 1.8.7 : update akuity kargo when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.7, 1.7.7, 1.6.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade kargo to 1.8.7, 1.7.7 or 1.6.3; akuity/kargo to 1.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| akuitykargo | Affected
| Fixed in
|
GitHubakuity/kargopkg:github/akuity/kargoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately verify their Kargo deployment versions and upgrade to at least 1.6.3, 1.7.7, or 1.8.7 as applicable. Since no workarounds exist, patching is critical. Additionally, organizations should restrict network access to Kargo API endpoints using firewall rules or network segmentation to limit exposure to trusted internal hosts. Implementing strict ingress controls and monitoring API usage patterns can help detect anomalous access attempts. Kubernetes clusters connected to Kargo should have robust role-based access controls (RBAC) and audit logging enabled to identify suspicious reconciliation triggers. Organizations should also review and rotate any credentials or tokens that may have been exposed due to this vulnerability. Finally, integrating vulnerability scanning and continuous monitoring for Kargo and related GitOps tools will help prevent future exploitation.
Description
CVE-2026-24748 is an incorrect authorization vulnerability in akuity's Kargo software versions prior to 1.8.7, 1.7.7, and 1.6.3. It allows unauthenticated attackers to access the GetConfig() API endpoint by providing any non-empty Bearer token, leading to exposure of configuration data such as Argo CD cluster endpoints. This information can be leveraged to enumerate cluster URLs and namespaces for further attacks. Additionally, the RefreshResource endpoint is vulnerable to unauthenticated denial-of-service attacks by triggering excessive Kubernetes resource reconciliations, potentially degrading API server performance.
References
- github.com/akuity/kargo/security/advisories/GHSA-w5wv-wvrp-v5m5 (opens in a new tab)
- github.com/akuity/kargo/commit/23646eaefb449a6cc2e76a8033e8a57f71369772 (opens in a new tab)
- github.com/akuity/kargo/commit/aa28f81ac15ad871c6eba329fc2f0417a08c39d7 (opens in a new tab)
- github.com/akuity/kargo/commit/b3297ace0d3b9e7f7128858c5c4288d77f072b8c (opens in a new tab)