Skip to main content
CVE-2026-2209VulnerabilityPublished Updated

CVE-2026-2209: WeKan · Improper Authorization

Affects WeKanSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
WeKanAffected
  • =8.0
  • =8.1
  • =8.2
  • =8.3
  • =8.4
  • =8.5
  • =8.6
  • =8.7
  • =8.8
  • =8.9
  • =8.10
  • =8.11
  • =8.12
  • =8.13
  • =8.14
  • =8.15
  • =8.16
  • =8.17
  • =8.18
Fixed in–
GitHubwekan/wekanpkg:github/wekan/wekanOther threatsAffected
  • =8.0
  • =8.1
  • =8.2
  • =8.3
  • =8.4
  • =8.5
  • =8.6
  • =8.7
  • =8.8
  • =8.9
  • =8.10
  • =8.11
  • =8.12
  • =8.13
  • =8.14
  • =8.15
  • =8.16
  • =8.17
  • =8.18
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade WeKan installations to version 8.19 or later, where the authorization flaw in setCreateTranslation has been corrected. Until upgrading is possible, organizations should restrict access to WeKan to trusted users only and enforce the principle of least privilege to minimize the number of users with permissions that could exploit this vulnerability. Monitoring and logging of translation-related activities can help detect suspicious behavior. Additionally, network-level controls such as IP whitelisting or VPN access can reduce exposure. Administrators should review user roles and permissions to ensure no unnecessary privileges are granted. Regularly auditing and updating software dependencies and components is essential to prevent similar authorization issues. Finally, educating users about the importance of reporting unexpected UI changes or translation anomalies can aid early detection.

Description

A vulnerability was detected in WeKan up to 8.18. The affected element is the function setCreateTranslation of the file client/components/settings/translationBody.js of the component Custom Translation Handler. The manipulation results in improper authorization. The attack can be launched remotely. Upgrading to version 8.19 is sufficient to fix this issue. The patch is identified as f244a43771f6ebf40218b83b9f46dba6b940d7de. It is suggested to upgrade the affected component.

References

Community reviews

Loading reviews…