CVE-2026-62263: OpenIdentityPlatform OpenAM · Deserialization of Untrusted Data
Affects OpenIdentityPlatform OpenAMSource CVE Database V5
Not known to be exploited · CVSS 9.2 Critical : upgrade to 16.1.2 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.1.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade OpenAM and openidentityplatform/OpenAM to 16.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenIdentityPlatformOpenAM | Affected
| Fixed in
|
GitHubopenidentityplatform/OpenAMpkg:github/openidentityplatform/OpenAMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenAM to version 16.1.2 or later, where this vulnerability is fixed. No other mitigations are indicated or effective since the vulnerability is in the deserialization logic and the fix is official. Patch status is confirmed by the vendor advisory indicating the issue is resolved in 16.1.2.
Description
CVE-2026-62263 is a critical deserialization vulnerability in OpenIdentityPlatform's OpenAM prior to version 16.1.2. The flaw arises because the WebAuthnAuthentication.deserialize method applies an ObjectInputFilter that insufficiently restricts serialized objects beyond the root AuthenticatorImpl object, allowing nested malicious gadget classes to execute code during deserialization. This vulnerability enables a pre-authentication attacker to bypass previous mitigations by supplying a crafted userHandle with a valid root object but malicious nested payloads. The issue is resolved in OpenAM version 16.1.2.