Skip to main content
VulnerabilityPublished

CVE-2026-33439: OpenIdentityPlatform OpenAM · Deserialization of Untrusted Data

Affects OpenIdentityPlatform OpenAMSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · public detection template (Nuclei) · CVSS 9.3 Critical : upgrade to 16.0.6 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
9.3% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade OpenAM and org.forgerock/openam to 16.0.6.

Affected software

ProductAffectedFixed in
OpenIdentityPlatformOpenAMAffected
  • <16.0.6
Fixed in
  • 16.0.6
Mavenorg.forgerock/openampkg:maven/org.forgerock/openamOther threatsAffected
  • <16.0.6
Fixed in
  • 16.0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in OpenAM version 16.0.6. Users should upgrade to version 16.0.6 or later to remediate this issue. Until upgraded, affected systems remain vulnerable. Patch status is not explicitly confirmed beyond the fixed version note; verify with the vendor advisory for the latest remediation guidance.

Description

OpenIdentityPlatform OpenAM versions prior to 16.0.6 contain a critical deserialization vulnerability (CWE-502) that allows unauthenticated remote code execution. The flaw arises from unsafe Java deserialization of the jato.clientSession HTTP parameter, bypassing previous mitigations applied to a similar parameter. An attacker can exploit this by sending a crafted serialized Java object to specific endpoints using JATO ViewBean JSPs, such as password reset pages. This vulnerability is fixed in version 16.0.6.

References

Community reviews

Loading reviews…