Skip to main content
VulnerabilityPublished Updated

CVE-2026-62296: hapifhir org.hl7.fhir.core · Improper Input Validation

Affects hapifhir org.hl7.fhir.coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.9.11 soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.9.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade org.hl7.fhir.core and ca.uhn.hapi.fhir:org.hl7.fhir.r5 and ca.uhn.hapi.fhir:org.hl7.fhir.utilities and ca.uhn.hapi.fhir:org.hl7.fhir.validation and ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli and org.hl7.fhir/core to 6.9.11.

Affected software

ProductAffectedFixed in
hapifhirorg.hl7.fhir.coreAffected
  • <6.9.11
Fixed in
  • 6.9.11
hapifhirca.uhn.hapi.fhir:org.hl7.fhir.r5Affected
  • <6.9.11
Fixed in
  • 6.9.11
hapifhirca.uhn.hapi.fhir:org.hl7.fhir.utilitiesAffected
  • <6.9.11
Fixed in
  • 6.9.11
hapifhirca.uhn.hapi.fhir:org.hl7.fhir.validationAffected
  • <6.9.11
Fixed in
  • 6.9.11
hapifhirca.uhn.hapi.fhir:org.hl7.fhir.validation.cliAffected
  • <6.9.11
Fixed in
  • 6.9.11
Mavenorg.hl7.fhir/corepkg:maven/org.hl7.fhir/coreOther threatsAffected
  • <6.9.11
Fixed in
  • 6.9.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to HAPI FHIR version 6.9.11 or later, where this issue is fixed. No other mitigations are indicated by the vendor advisory.

Description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.11, XhtmlParser.java imposes no maximum element nesting depth, so a deeply nested text.div narrative triggers unbounded recursion between parseElementInner() and parseElement(), raising a StackOverflowError. An attacker who can submit FHIR resources containing such narratives can thus crash a parsing or validation worker thread, affecting validator services and any application that parses attacker-supplied FHIR JSON or XML. This issue is fixed in version 6.9.11.

References

Community reviews

Loading reviews…