Skip to main content
VulnerabilityPublished Updated

CVE-2026-62354: Apache NiFi · Incorrect Authorization

Affects Apache NiFiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/S:P/AU:Y/R:I/V:C/RE:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache NiFiAffected
  • >=1.10.0 <=2.10.0
Fixed in–
Mavenorg.apache.nifi/nifipkg:maven/org.apache.nifi/nifiOther threatsAffected
  • =1.10.0
  • <=2.10.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache NiFi to version 2.11.0 or later, where the vulnerability is fixed by requiring write access to submit Parameter Context validation requests. If upgrading is not immediately possible, ensure that authorization policies enforce different levels of access for viewing and modifying Parameter Context configurations to prevent exploitation.

Description

Authorization handling for Parameter Context validation requests in Apache NiFi 1.10.0 through 2.10.0 allows clients with read access to submit proposed Parameter values. The proposed values override current configuration, enabling users with read access to invoke predefined component validation methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying Parameter Context configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, requiring write access to submit Parameter Context validation requests.

References

Community reviews

Loading reviews…