CVE-2026-44911: Apache NiFi · Incorrect Authorization
Affects Apache NiFiSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low · fixed in 2.10.0 : update Apache NiFi when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/AU:Y/R:U/V:C/RE:L/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 22 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache NiFi | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.nifi:nifi-web-apipkg:maven/Apache Software Foundation/org.apache.nifi:nifi-web-apiOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache NiFi to version 2.10.0 or later, which requires write access to submit configuration verification requests, effectively mitigating this vulnerability. If upgrading is not immediately possible, ensure that your NiFi installation enforces different authorization levels for viewing and modifying component configurations to prevent exploitation. Patch status is not explicitly confirmed beyond the recommendation to upgrade to 2.10.0; check the official Apache NiFi advisory for the latest remediation guidance.
Description
Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.