CVE-2026-62364: WeblateOrg wlc · Information Exposure
Affects WeblateOrg wlcSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 2.0.1 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.08% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.1
CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade wlc and weblateorg/wlc to 2.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WeblateOrgwlc | Affected
| Fixed in
|
GitHubweblateorg/wlcpkg:github/weblateorg/wlcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade wlc to version 2.0.1 or later, where this issue is fixed. Until then, avoid running wlc in untrusted repositories or directories with unscoped API tokens supplied via WLC_KEY or --key without a matching URL. Use URL-scoped API tokens defined in the [keys] section to mitigate risk.
Description
CVE-2026-62364 is a vulnerability in WeblateOrg's wlc command-line client prior to version 2.0.1. The issue involves exposure of an unscoped API token when wlc automatically discovers configuration files and uses the token without a matching URL. This can cause the token to be sent to an attacker-controlled URL if wlc runs in an untrusted repository or directory. The vulnerability is fixed in version 2.0.1.
References
- github.com/WeblateOrg/wlc/security/advisories/GHSA-3mqq-hv9c-85hc (opens in a new tab)
- github.com/WeblateOrg/wlc/pull/1500 (opens in a new tab)
- github.com/WeblateOrg/wlc/commit/15cbdfc5b2c6183ef6864ea758091643a0ce6c89 (opens in a new tab)
- github.com/WeblateOrg/wlc/releases/tag/2.0.1 (opens in a new tab)