CVE-2026-62662: pocket-id · Improper Input Validation
Affects pocket-idSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 2.10.0 soon.
Data as of 4 Nov 2026, 23:44 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.0 | 7.7 |
|---|
- Patch
- Available – fixed in 2.10.0
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade pocket-id and pocket-id/pocket-id to 2.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pocket-idpocket-id | Affected
| Fixed in
|
GitHubpocket-id/pocket-idpkg:github/pocket-id/pocket-idOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Pocket ID to version 2.10.0 or later, where this vulnerability is fixed. No other mitigations are specified. Since this is a code-level validation flaw, patching is the recommended and effective remediation.
Description
CVE-2026-62662 is a high-severity vulnerability in Pocket ID versions from 1.11.0 up to but not including 2.10.0. The flaw involves improper input validation in the createTokenFromClientCredentials function, which allows any authenticated OIDC client to obtain access tokens with arbitrary or unauthorized audiences. This bypasses audience-based access controls in deployments that rely on these tokens for service-to-service authorization, potentially permitting unauthorized data access or actions. The issue is fixed in version 2.10.0.
References
- github.com/pocket-id/pocket-id/security/advisories/GHSA-q4xm-p75h-h9p3 (opens in a new tab)
- github.com/pocket-id/pocket-id/pull/1520 (opens in a new tab)
- github.com/pocket-id/pocket-id/commit/8158452b37304115c97c61c3a56082ce938ce6f0 (opens in a new tab)
- github.com/pocket-id/pocket-id/releases/tag/v2.10.0 (opens in a new tab)