CVE-2026-6290: Rapid7 Velociraptor · Incorrect Authorization
Affects Rapid7 VelociraptorSource CVE Database V5
Not known to be exploited · CVSS 8.0 High : upgrade to 0.76.3 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.76.3
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Rapid7 Velociraptor to 0.76.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Rapid7Velociraptor | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the Velociraptor GUI to trusted users only and consider limiting notebook usage or query() plugin access.
Description
CVE-2026-6290 is a vulnerability in Rapid7 Velociraptor versions prior to 0.76.3 affecting the query() plugin. It allows an authenticated GUI user with access to one organization to run VQL queries on other organizations using the same ACL token, effectively bypassing intended access controls. The user's permissions in the other organizations mirror those in the original organization where the notebook is located. This vulnerability has a high severity with a CVSS score of 8.