CVE-2026-62958: libriscv · Improper Input Validation
Affects libriscvSource CVE Database V5
Not known to be exploited · CVSS 7.9 High : upgrade to 1.18 soon.
Data as of 30 Oct 2026, 21:06 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.9 |
|---|
- Patch
- Available – fixed in 1.18
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade libriscv and libriscv/libriscv to 1.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| libriscvlibriscv | Affected
| Fixed in
|
GitHublibriscv/libriscvpkg:github/libriscv/libriscvOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade libriscv to version 1.18 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Users should apply the official patch to prevent exploitation.
Description
CVE-2026-62958 is a high-severity vulnerability in libriscv, a RISC-V sandbox and emulator, affecting versions prior to 1.18. It involves improper input validation of ELF binaries, where crafted binaries can cause out-of-bounds reads in the host emulator. This occurs because certain section-header offsets are not properly verified against the binary size, allowing access outside the intended memory buffer. The flaw can lead to host crashes (SIGSEGV) and potentially expose host memory to the guest environment. The issue is fixed in libriscv version 1.18.
References
- github.com/libriscv/libriscv/security/advisories/GHSA-gm4g-6c78-gr3w (opens in a new tab)
- github.com/libriscv/libriscv/commit/61ef9ca82c8876dd80b33780893ba512af780e93 (opens in a new tab)
- github.com/libriscv/libriscv/commit/7bd1c189f9f9d54368cde096b07b194ad680f9fa (opens in a new tab)
- github.com/libriscv/libriscv/releases/tag/v1.18 (opens in a new tab)