CVE-2026-6328: XQUIC · Improper input validation
Affects XQUICSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 1.9.0 soon.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.0, 1.8.4
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade XQUIC and xquic to 1.9.0; alibaba/xquic to 1.8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| XQUIC ProjectXQUIC | Affected
| Fixed in
|
GitHubalibaba/xquicpkg:github/alibaba/xquicOther threats | Affected
| Fixed in
|
GitHubxquicpkg:github/xquicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider limiting exposure of affected XQUIC services to untrusted networks if feasible.
Description
CVE-2026-6328 is a high-severity vulnerability in the XQUIC Project's xquic implementation on Linux. It involves improper input validation and improper verification of cryptographic signatures in the QUIC protocol's packet processing and STREAM frame handler modules. This flaw allows protocol manipulation. The vulnerability affects versions up to 1.8.3 of XQUIC.