Skip to main content
VulnerabilityPublished

CVE-2026-63329: warp-tech warpgate · Improper Encoding or Escaping of Output

Affects warp-tech warpgateSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.9 Medium : upgrade to 0.25.6 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.25.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade warpgate and warp-tech/warpgate to 0.25.6.

Affected software

ProductAffectedFixed in
warp-techwarpgateAffected
  • <0.25.6
Fixed in
  • 0.25.6
GitHubwarp-tech/warpgatepkg:github/warp-tech/warpgateOther threatsAffected
  • <0.25.6
Fixed in
  • 0.25.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade warpgate to version 0.25.6 or later, where this vulnerability is fixed. No other mitigation is required as the official fix addresses the issue.

Description

CVE-2026-63329 is a medium severity vulnerability in warp-tech warpgate, an open source SSH, HTTPS, and MySQL bastion host for Linux. Versions prior to 0.25.6 improperly forward client-supplied x-warpgate-username headers, allowing an authenticated attacker to potentially impersonate another user if the backend trusts the first header value. The vulnerability also involves acceptance of the reserved x-warpgate-authentication-type header without exclusion. This issue is fixed in version 0.25.6.

References

Community reviews

Loading reviews…