CVE-2026-91164: warp-tech warpgate · Improper Access Control
Affects warp-tech warpgateSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 0.27.3 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.27.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade warpgate and warp-tech/warpgate to 0.27.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| warp-techwarpgate | Affected
| Fixed in
|
GitHubwarp-tech/warpgatepkg:github/warp-tech/warpgateOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade warpgate to version 0.27.3 or later, where this improper access control issue is fixed. If upgrading immediately is not possible, consider disabling allowed_ip_ranges or restricting token distribution to trusted environments as a temporary measure. No other mitigations are documented. Patch status is confirmed fixed in 0.27.3.
Description
Warpgate is an open source SSH, HTTPS and MySQL bastion host for Linux. From 0.23.0 until 0.27.3, HTTP API token authentication resolves ConfigProvider::validate_api_token into RequestAuthorization::UserToken without enforcing the owning user's allowed_ip_ranges against the trusted client address in warpgate-protocol-http/src/common.rs. An attacker holding a leaked, phished, or exfiltrated X-Warpgate-Token can therefore use it from a prohibited network location. Deployments without allowed_ip_ranges are unaffected, and HTTP target proxying plus SSH, MySQL, PostgreSQL, RDP, VNC, and Kubernetes paths do not accept this vulnerable HTTP token flow. This issue is fixed in version 0.27.3.
References
- github.com/warp-tech/warpgate/security/advisories/GHSA-qmr2-wp96-h9ff (opens in a new tab)
- github.com/warp-tech/warpgate/pull/2356 (opens in a new tab)
- github.com/warp-tech/warpgate/commit/8cb33a1a7c447ab0cde3a1ee9f95bf9dde905482 (opens in a new tab)
- github.com/warp-tech/warpgate/releases/tag/v0.27.3 (opens in a new tab)