CVE-2026-6366: Drupal core · Mass Assignment
Affects Drupal coreSource CVE Database V5
Not known to be exploited · CVSS 6.6 Medium · fixed in 11.3.7 : update Drupal core when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.3.7, 11.2.11, 10.6.7 +1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal core to 11.3.7, 11.2.11, 10.6.7 or 10.5.9; drupal/core to 11.2.11, 10.6.7 or 10.5.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalDrupal core | Affected
| Fixed in
|
| DrupalDrupal core | Affected
| Fixed in
|
| DrupalDrupal core | Affected
| Fixed in
|
| DrupalDrupal core | Affected
| Fixed in
|
Packagistdrupal/corepkg:composer/drupal/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to privileged accounts and monitor for suspicious activity related to object manipulation. Avoid upgrading to affected versions and consider applying any available security updates once published by Drupal.
Description
CVE-2026-6366 is a vulnerability in Drupal core that involves improper control over modification of dynamically-determined object attributes, leading to object injection. It affects multiple versions of Drupal core from 8.0.0 up to versions before 10.5.9, 10.6.7, 11.2.11, and 11.